La presentazione è in caricamento. Aspetta per favore

La presentazione è in caricamento. Aspetta per favore

21-12-111Informatica di Base - J. Lin1 Informatica di Base – A.A. 2011-12 Lezione 15 Excel Filtro, Ordinamento e Grafici.

Presentazioni simili


Presentazione sul tema: "21-12-111Informatica di Base - J. Lin1 Informatica di Base – A.A. 2011-12 Lezione 15 Excel Filtro, Ordinamento e Grafici."— Transcript della presentazione:

1 Informatica di Base - J. Lin1 Informatica di Base – A.A Lezione 15 Excel Filtro, Ordinamento e Grafici

2 Informatica di Base - J. Lin22 Funzione SE Sintassi: =SE(condizione; val1; val2) La funzione SE dà il risultato di val1 se si verifica la condizione, altrimenti dà il risultato di val2. OSS: Le stringhe vanno racchiuse tra virgolette. Si concatenano con loperatore & Es.: Supponiamo che A1-A2 sia un saldo (positivo o negativo). In una cella scriviamo: =SE(A1-A2>=0;Credito di & A1;Debito di & A1)

3 Funzione SE Es.: =SE(E4=0; rifornimento;) Appare la parola rifornimento se la cella E4 ha valore 0. Informatica di Base - J. Lin3

4 Formato Cella Facendo click dx\Formato Celle è possibile specificare il formato della cella: Excel Informatica di Base - J. Lin4 visualizza il risultato della cella in un modo dipendente dal tipo di valori specificato. Es.: specificando Valuta, compare il simbolo ; specificando Data appare come gg/mm/aaaa, … OSS: Però il contenuto della cella non cambia.

5 Ordinamento E possibile ordinare i dati di una sottotabella in base ai valori di una o più colonne, dette chiavi. Il comando di ordinamento si dà tramite la finestra Ordina accessibile dal menù Dati\Ordina OSS: Se si selezionano alcune celle, Excel applicherà lordinamento solo alle celle selezionate, altrimenti Excel cercherà di determinare automaticamente la sottotabella da ordinare. Informatica di Base - J. Lin5

6 Ordinamento Si possono specificare fino a 3 chiavi/colonne di ordinamento. Lordine può essere crescente o decrescente. Informatica di Base - J. Lin6 Se la prima riga contiene le intestazioni (nomi) delle colonne possiamo scegliere lopzione Con riga dintestazione che così esclude le celle della prima riga, che vengono usate come chiavi. Es: Conto Clienti.xls

7 Filtri I filtri permettono di vedere solo porzioni di tabella, ovvero solo le righe della tabella che rispettano certi criteri. Es.: abbiamo una rubrica telefonica e vogliamo vedere tutti e solo i contatti di Milano. Excel dispone di 2 modalità di filtri: automatici e avanzati. Per il filtro automatico è necessario: 1) attivare il filtro, 2) specificare i criteri del filtro. 1) Si seleziona una colonna, altrimenti Excel determina automaticamente lintera tabella… Informatica di Base - J. Lin7

8 Filtro automatico Poi si attiva il filtro dal menù Dati\Filtro\Filtro automatico. 2) Si selezionano i criteri sulle colonne desiderate. Selezionando un valore presente nei dati vengono visualizzate solo le righe contenenti quel valore nella colonna. Altri criteri sono Tutto (non filtra), Vuote/NonVuote (righe che hanno o meno un valore nella colonna), … Informatica di Base - J. Lin8

9 Filtro automatico 2) … Personalizza (permette di specificare criteri complessi come prefisso/suffisso di stringa, intervalli numeri, formati da più condizioni in AND od OR). OSS: I filtri non modificano i dati, ma nascondono solo le righe che non rispettano i criteri di filtraggio su tutte le colonne in cui è attivo il filtro. Si può fissare la riga dintestazione (non scorre): posizionarsi sulla prima riga non dintestazione, poi menù Finestra\Blocca riquadri Informatica di Base - J. Lin9

10 Grafici: disegnare una funzione Excel permette di costruire diversi grafici, compresi istogrammi, superfici, scatter plot, … tramite il menù Inserisci\Grafico. Vediamo come disegnare una funzione y=f(x) in un intervallo. Informatica di Base - J. Lin10 Dobbiamo avere i vettori X delle ascisse, e Y delle ordinate corrispondenti. Selezioniamo il vettore Y e inseriamo il grafico di Tipo: Linee con indicatori assieme ai valori.

11 Informatica di Base - J. Lin11 Grafici: disegnare una funzione Premendo Avanti si possono scegliere i dati da utilizzare. Nella scheda Serie compare già la serie (vettore) Y con relativo Nome. Bisogna specificare il vettore X nel campo Etichette asse categorie(X): è sufficiente posizionarsi nel campo e selezionare il vettore X. Premendo Avanti si possono impostare alcuni attributi aggiuntivi del grafico, es.: titolo, nomi degli assi, griglie orizzontali e verticali, …

12 Informatica di Base - J. Lin12 Esercizio: grafico Disegnare il grafico per la funzione y=f(x) dellesercizio precedente, e anche della funzione y=F(x) se è stato costruito. Impostare come titolo del grafico Integrazione numerica di una funzione tramite la Regola del Trapezio, e come nomi delle due serie f(x) e F(x).


Scaricare ppt "21-12-111Informatica di Base - J. Lin1 Informatica di Base – A.A. 2011-12 Lezione 15 Excel Filtro, Ordinamento e Grafici."

Presentazioni simili


Annunci Google