La presentazione è in caricamento. Aspetta per favore

La presentazione è in caricamento. Aspetta per favore

1 Laboratorio di Excel Excel 2000: Introduzione Selezione dei Fogli e Navigazione Modifica dellaspetto dei Fogli di lavoro Inserimento di Dati Calcoli:

Presentazioni simili


Presentazione sul tema: "1 Laboratorio di Excel Excel 2000: Introduzione Selezione dei Fogli e Navigazione Modifica dellaspetto dei Fogli di lavoro Inserimento di Dati Calcoli:"— Transcript della presentazione:

1 1 Laboratorio di Excel Excel 2000: Introduzione Selezione dei Fogli e Navigazione Modifica dellaspetto dei Fogli di lavoro Inserimento di Dati Calcoli: riferimenti e formule Modifica dei Dati

2 2 Fogli e Cartelle Un foglio di lavoro o di calcolo è il supporto atto alla memorizzazione ed elaborazione di dati. È costituito da celle disposte in righe e colonne. Una cartella di lavoro in Excel è una raccolta di fogli di calcolo. Il numero di fogli che essa può contenere è limitato dalle risorse del sistema. Viene salvata in un file avente Tipo file: Cartella di lavoro Microsoft Excel.

3 3 Aspetto di una Cartella Barra dei Menù Barra Standard Barra della formula Elenco dei Fogli di lavoro Barre di Scorrimento Barra del titolo Barra di Formattazione righe 256 colonne Pulsanti di Scorrimento Fogli Foglio Selezionato Casella Nome

4 4 Cella D5 Celle Un cella è lintersezione di una riga e di una colonna in un foglio di lavoro. Un indirizzo di cella, o riferimento alla cella, è la posizione di una cella nel foglio ed è espresso con la lettera della colonna e con il numero di riga corrispondenti

5 5 Range B3:D10 Intervalli Un blocco rettangolare di celle adiacenti è detto range o intervallo di celle. Bottom right Top left

6 6 Rinominare un Foglio 1.Premere il pulsante destro del mouse sulla scheda del foglio di lavoro 2.Scegliere il comando rinomina 3.Inserire il nuovo nome 4.Premere Invio oppure 1.Doppio click con il pulsante sinistro del mouse sulla scheda del foglio di lavoro 2.Inserire il nuovo nome 3.Premere Invio

7 7 Selezionare i Fogli Selezionare un singolo foglio: - Click con il pulsante sinistro del mouse sulla scheda Selezionare un gruppo di fogli: - Selezionare il primo foglio da includere nel gruppo fogli non adiacenti: Ctrl+click con il pulsante sinistro del mouse sui fogli da includere nel gruppo fogli adiacenti: Shift+click con il pulsante sinistro del mouse sullultimo foglio del gruppo N.B.: Selezionato un gruppo di fogli, le modifiche apportate a uno dei si ripercuotono su tutti gli altri. Deselezionare un gruppo di fogli: - Click con il pulsante sinistro del mouse su un foglio non appartenente al gruppo

8 8 Spostarsi allinterno di un Foglio In basso di una cella: Invio o freccia direzionale In alto di una cellla: Shift+Invio o freccia direzionale A destra di una cella: Tab o freccia direzionale A sinistra di una cella: Shift+Tab o freccia direzionale A una cella specificata: digitare lindirizzo della cella nella casella Nome

9 9 Selezionare Celle in un Foglio Selezione di una cella: click sulla cella Selezione di un intervallo di celle: click e trascinare la selezione sulle celle Selezione di una intera riga/colonna: click sul numero di riga/lettera della colonna Selezione di celle non adiacenti: click su una delle celle da selezionare, successivamente Ctrl+click sulle altre celle da selezionare Selezione di celle adiacenti: click sulla prima cella, successivamente Shift+click sullultima cella da selezionare

10 10 … continua Selezione intervallo B5:D8 cliccare sulla cella B5 trascinare il cursore con il pulsante sinistro del mouse premuto fino alla cella D8 rilasciare il pulsante del mouse. N.B.: il simbolo : separa la coppia di coordinate che individuano lintervallo (range) di celle adiacenti.

11 11 Aggiungere/Eliminare Fogli Inserire un foglio vuoto in una cartella: -click con il pulsante destro del mouse sul foglio che deve immediatamente seguire quello nuovo -scegliere il comando Inserisci -scegliere licona Foglio di lavoro Eliminare un foglio vuoto in una cartella: -click con il pulsante destro del mouse sul foglio da eliminare -scegliere il comando Elimina -confermare la scelta N.B.: un foglio eliminato non può essere recuperato Più fogli di lavoro nella stessa cartella di lavoro permettono una migliore organizzazione logica dei dati.

12 12 …oppure Selezionare il foglio a destra del punto dove inserire quello nuovo. Inserisci - Foglio di Lavoro Il Foglio 4 è inserito nel punto desiderato.

13 13 …oppure Selezionare il Foglio di lavoro da eliminare. Modifica - Elimina Foglio Confermare.

14 14 Spostare/Copiare Fogli Spostare un foglio allinterno di una stessa cartella: -selezionare la scheda del foglio da spostare -trascinare la scheda del foglio nella posizione desiderata Copiare un foglio allinterno di una stessa cartella: -selezionare la scheda del foglio da copiare -trascinare la scheda del foglio nella punto in cui si desidera posizionare la copia -premere Ctrl -rilasciare il pulsante sinistro del mouse

15 15 …continua Spostare/Copiare un foglio in una cartella diversa da quella di appartenenza: -aprire entrambe le cartelle di lavoro -click con il pulsante destro del mouse sulla scheda del foglio da spostare/copiare -scegliere il comando sposta o copia -effettuare le scelte desiderate nella finestra di dialogo Nome della cartella in cui effettuare la copia Indicare la posizione in cui copiare il foglio Check per effettuare una copia

16 16 …continua Spostare/Copiare un foglio in una cartella diversa da quella di appartenenza: -aprire entrambe le cartelle di lavoro -disporre le finestre in modo che le schede dei fogli di entrambe le cartelle siano visibili -seguire le azioni per spostare/copiare fogli allinterno della cartella di lavoro di appartenenza

17 17 Bloccare i Riquadri I riquadri permettono di mantenere alcune celle sempre in vista indipendentemente dagli spostamenti nel foglio di lavoro. Bloccare i riquadri in un foglio di lavoro: -selezionare la cella il cui angolo superiore sinistro determina la posizione dei riquadri -Finestra – Blocca riquadri Sbloccare i riquadri in un foglio di lavoro: -Finestra – Sblocca riquadri

18 18 Procedura di inserimento: Selezionare la cella Digitare i dati Dati Tipi di dato: Testo: combinazione di lettere, numeri, simboli e spazio Numerico Data/Ora Valori di tipo testo. Valori di tipo numerico. Valori di tipo data e ora.

19 19 Il Riempimento Il riempimento permette di inserire una serie di dati per trascinamento: o Testo da elenchi predefiniti o Testo da elenchi personalizzati o Testo identico in tutte le celle o Numeri con tendenza lineare o Numeri con tendenza esponenziale o Altro

20 20 Serie numerica lineare a 1 = α a n = a n – 1 + k due numeri successivi della serie hanno differenza costante uguale a k. Serie numerica esponenziale a 1 = α a n = k · a n – 1 due numeri successivi della serie hanno rapporto costante uguale a k.

21 21 Riempimento: elenchi predefiniti -selezionare la cella in cui effettuare linserimento -digitare una voce di un elenco predefinito -posizionare il puntatore del mouse sullangolo inferiore destro della cella selezionata -trascinare al momento in cui il puntatore assume la forma di una croce nera

22 22 Riempimento: elenchi personalizzati Creare un elenco personalizzato: -inserire un elenco personalizzato nel foglio di lavoro -selezionare lintervallo di celle che lo contiene -Strumenti – Opzioni – Elenchi -scegliere importa oppure -Opzioni – Strumenti – Elenchi -selezionare Nuovo Elenco -aggiungere le voci che compongono il nuovo elenco -premere Ok Eliminare un elenco: -Strumenti – Opzioni – Elenchi -selezionare lelenco da eliminare -premere il pulsante Elimina

23 23 Riempimento: testo identico Se le voci di testo inserite non sono riconosciute come appartenenti ad un elenco, le celle vengono riempite copiando le voci.

24 24 Riempimento: serie numerica lineare -selezionare la cella in cui effettuare linserimento -digitare un numero -digitare il numero successivo della serie in una cella adiacente -selezionare entrambe le celle -trascinare il quadratino di riempimento

25 25 Riempimento: serie numerica esponenziale -selezionare la cella in cui effettuare linserimento -digitare un numero -digitare il numero successivo della serie in una cella adiacente -selezionare entrambe le celle -trascinare il quadratino di riempimento con il pulsante destro del mouse -scegliere Tendenza esponenziale dal menu che compare

26 26 Inserire Dati Duplicati -selezionare le celle in cui effettuare linserimento -digitare il dato -premere Ctrl+Invio

27 27 Moduli di Inserimento Dati -inserire le intestazioni di colonna e almeno una riga di dati -clickare su una cella nella tabella -Dati - Modulo -inserire i dati nella finestra di dialogo

28 28 Convalida di Dati Impostare la convalida dei dati permette di prevenire inserimenti errati e indesiderati, visualizzando un messaggio di errore/attenzione in risposta ai dati inseriti che non soddisfano i criteri stabiliti. Impostare la convalida dei dati -selezionare la cella o lintervallo di celle di cui convalidare i dati -Dati - Convalida Tipo di dato consentito Impostazione criterio Rende obbligatorio linserimento di un valore nella cella Testo che compare nella barra del titolo del messaggio visualizzato Testo che compone il corpo del messaggio visualizzato quando è selezionata una delle celle soggette alla convalida Tipo di messaggio visualizzato Per non visualizzare alcun messaggio Testo che compone il corpo del messaggio visualizzato quando sono immessi dati non validi Testo che compone il titolo del messaggio visualizzato quando sono immessi dati non validi Per non visualizzare alcun messaggio

29 29 …continua Rimuovere la convalida dei dati -selezionare la cella in cui è attivata la convalida dei dati -Dati – Convalida Rimuovere la convalida Rimuovere le stesse impostazioni di convalida da tutte le celle cui sono applicate

30 30 I dati non validi già presenti nel foglio di lavoro non generano messaggi di errore. Gli stili di errore Informazione e Avviso permettono di inserire i dati non validi dopo che sono stati visualizzati i messaggi di errore, mentre lo stile di errore Interruzione impedisce di inserire i dati non validi. Per determinare le celle in un foglio di lavoro soggette alla convalida dei dati: -Modifica- Vai -Scegliere speciale Osservazioni

31 31 I Riferimenti di Cella Un riferimento di cella è lindirizzo della cella nel foglio di lavoro, composto dalla lettera di colonna e dal numero di riga.

32 32 Formule e Funzioni In Excel le elaborazioni numeriche possono essere effettuate tramite: formule utente funzioni predefinite Le funzioni sono formule chiavi in mano, residenti in EXCEL; hanno un algoritmo di calcolo già definito.

33 33 …continua Le formule sono espressioni contenenti: - riferimenti a celle - operatori matematici - operatori relazionali - funzioni - parentesi - non possono contenere né grafici né figure Esempio: = (A1+A2+A3)/3 Le formule iniziano con = e sono inserite nella barra della formula della cella. Nella cella di solito è visualizzato il risultato del calcolo della formula.

34 34 Operatori matematici +addizione - sottrazione *moltiplicazione /divisione ^ elevamento a potenza ( ) parentesi Seguono le classiche regole di priorità. Operatori con la stessa priorità vengono eseguiti da sinistra verso destra. Le parentesi alterano le priorità

35 35 Operatori relazionali (di confronto) maggiore di =uguale a <>diverso da

36 36 Esempio Selezione: selezionare la cella che conterrà il risultato della formula. Inserire la formula desiderata. Confermare con Invio o con il check verde. Il risultato della formula viene visualizzato nella cella.

37 37 Inserimento di una Formula -digitare la formula per intero nella barra della formula -usare il mouse per inserire i riferimenti di cella

38 38 Visualizzare Formule Normalmente una cella contiene il risultato della formula che vi è stata inserita. Il testo della formula invece appare nella barra della formula. Tuttavia è possibile visualizzare nella cella il testo della formula stessa. Menu Strumenti - Opzioni check box Formule

39 39 Selezionare la cella contente la formula. La formula appare nella barra della formula. Modificare la formula. Co nfermare la modifica. Modifica di Formule La modifica delle formule è analoga alla modifica del contenuto di una cella.

40 40 Copiare Formule Copiando una formula, la composizione della stessa è adattata alla cella di arrivo: gli indirizzi contenuti nella formula di partenza vengono adattati alla riga e alla colonna della cella di destinazione. Selezionata la cella, Modifica - Copia Spostarsi nella cella di destinazione, Modifica - Incolla. Indirizzi aggiornati.

41 41 … continua Esiste un modo di copiare celle (e quindi formule) molto utile per copiare formula su celle adiacenti. Selezionare la cella contenente la formula, trascinare il quadratino di riempimento

42 42 Tipi di Riferimento Assoluto: posizione fissa Esempio: $A$1 Relativo: posizione relativa Esempio: A1 Misto: misto di posizione fissa e relativa Esempio: $A1,A$1 $ rende fisso il riferimento di riga/colonna

43 43 Riferimenti Assoluti $A$4 $B$3 $C$6

44 44 Riferimenti Relativi F-D=2 9-4=5 A4 C9 B3 D8 C6 E11

45 45 Riferimenti Misti F-D=2 9-4=5 $A4 $A9 B$3 D$3 $C6 $C11

46 46 Esempio Filmato: file TavolaSomma.aviTavolaSomma.avi Filmato: file TavolaSommaProdotto.aviTavolaSommaProdotto.avi

47 47 Riferimenti a Celle di Cartelle Diverse Una formula che collega cartelle di lavoro è una formula che fa riferimento a celle presenti in più di una cartella. Scrivere una formula con riferimenti a celle di cartelle diverse: -aprire le cartelle di lavoro interessate -inserire un riferimento a celle di cartelle diverse nella formula in oggetto cliccando sulla apposita cella. Riferimento alla cella A1 del Foglio 1 della cartella Euro.xls aperta con Excel:[Euro.xls]Foglio1!$A$1 Riferimento alla cella A1 del Foglio 1 della cartella Euro.xls non aperta con Excel: 'path\[Euro.xls]Foglio1'!$A$1

48 48 …continua Aprendo una cartella che contiene una formula con riferimenti a celle di altre cartelle è possibile: aggiornare la formula con i valori attuali presenti nelle cartelle di origine, lasciare i valori precedenti.

49 49 Riferimenti a Celle di Fogli diversi Una formula può contenere riferimenti a celle di fogli diversi. Riferimento alla cella A1 del Foglio3 appartenente alla stessa cartella: Foglio3!A1

50 50 Copiare il risultato di una formula Modifica – Incolla speciale Notare la differenza fra copiare una formula e copiare il risultato di una formula. Quando si copia una formula in unaltra cella in questultima generalmente compare un risultato diverso (se la formula contiene ad esempio riferimenti relativi o misti). A volte può risultare utile copiare solo il risultato della formula in unaltra cella.

51 51 Celle di Origine Con il termine celle di origine o precedenti si intendono le celle referenziate da una cella contenente una formula che includa riferimenti validi. Trovare le celle di origine: -selezionare la cella contenente la formula -Strumenti – Verifica formule – Individua precedenti N.B.: in qualche versione di Excel la voce di menu Verifica formule è sostituita da Controllo.

52 52 Celle Dipendenti Con il termine celle di dipendenti si intendono le celle che referenziano la cella in oggetto. Trovare le celle dipendenti: -selezionare la cella contenente la formula -Strumenti – Verifica formule – Individua dipendenti Per rimuovere dal foglio le linee di controllo: -Strumenti – Verifica formule – Rimuovi tutte le frecce

53 53 Inserire righe/colonne Selezionare la cella/celle dove inserire la riga/colonna. Inserisci - Righe o Colonne Le righe inserite presentano la stessa formattazione delle celle soprastanti; le colonne inserite presentano la stessa formattazione delle celle sulla sua sinistra.

54 54 … continua Selezione. Inserisci - Colonne. Inserimento della nuova colonna a sinistra della selezione.

55 55 … continua Selezione. Inserisci - Righe. Inserimento della nuova riga sotto la selezione.

56 56 Eliminare righe/colonne Selezionare la cella/celle appartenente alla riga/colonna da eliminare. Modifica - Elimina

57 57 Inserire celle Selezionare larea in cui inserire le celle. Inserisci - Celle Modalità di spostamento delle celle esistenti. Celle inserite.

58 58 Eliminare celle Selezionare le celle. Modifica - Elimina. Leliminazione ha shiftato le celle sottostanti verso lalto.

59 59 … continua Selezionare le celle. Modifica - Elimina. Leliminazione ha shiftato le celle sulla destra verso sinistra.

60 60 Unione di celle -digitare il testo in una cella -selezionare celle adiacenti oggetto di unione -premere il pulsante unisci celle oppure Formato – Celle:scheda allineamento Opzione unione celle.

61 61 Laboratorio di Excel Funzioni Formattazioni di Celle

62 62 Le Funzioni Le funzioni sono procedure predefinite che eseguono elaborazioni anche complesse. Esempio: A1+B1+C1+D1+E1+F1+G1+H1 equivale a SOMMA(A1:H1)

63 63 Elementi caratterizzanti una Funzione Sintassi: =parolachiave(lista di argomenti) parolachiave: nome della funzione lista di argomenti: insieme ordinato, eventualmente vuoto, di argomenti separati da ; Un argomento rappresenta linput sul quale effettuare le elaborazioni. Può essere:un numero, una stringa, una cella, un intervallo, una formula. Un argomento non può essere né una figura né un grafico. Esempio: SOMMA(A1:H1) N.B.: non inserire spazi nella digitazione di funzioni. parola chiave un solo argomento di tipo intervallo (range)

64 64 Categorie di Funzioni Le funzioni che si possono usare nei fogli di lavoro Excel sono suddivise per categorie: Database Data e ora Finanziarie Informative Logiche Ricerca e riferimento Matematiche e trigonometriche Statistiche Testo

65 65 Per un panorama completo delle funzioni disponibili, scegliere Creazione di formule e controllo di cartelle di lavoro e successivamente Funzioni del foglio di lavoro dal Sommario della guida in linea di Excel.

66 66 Inserire Funzioni Autocomposizione 1.cliccare sulla cella in cui desiderate inserire i risultati della formula 2.inserisci – Funzione o pulsante Incolla funzione 3.selezionare una categoria di funzioni e una funzione

67 67 …continua 4.inserire gli argomenti richiesti 5.premere Ok Oppure 1.cliccare sulla cella in cui desiderate inserire i risultati della formula 2.digitare direttamente il nome e gli argomenti della formula nella barra della formula Argomenti Risultato Descrizione

68 68 SOMMA (funzione matematica) sintassi:=SOMMA(num1;…; num30) Ignora le celle vuote, contenenti valori logici, testo. Esempio: = SOMMA(3;2) = SOMMA(B2:E2;15;A1) ARROTONDA (funzione matematica) sintassi:=ARROTONDA(num;num_cifre) num: numero da arrotondare num_cifre: numero di cifre a cui arrotondare Esempio: =ARROTONDA(2,15; 1)

69 69 RADQ (funzione matematica) sintassi:=RADQ(num) num: numero di cui calcolare la radice quadrata Esempio: =RADQ(16) =RADQ(-16) ERRORE ASS (funzione matematica) sintassi:=ASS(num) num: numero di cui calcolare il valore assoluto Esempio: =ASS(16) =ASS(-16)

70 70 sintassi:=CONTA.VALORI(val1;…;val30) Ignora celle vuote, ma non il testo vuoto Esempio: =CONTA.VALORI(A1:A5) =CONTA.VALORI(A1:A5;pippo) CONTA.VALORI (funzione statistica) = CONTA.VALORI(B9:E9)

71 71 CONTA.VUOTE (funzione informativa) sintassi:=CONTA.VUOTE(intervallo) Conta celle vuote e risultato di formule Esempio: =CONTA.VUOTE(A1:A5) sintassi:=CONTA.NUMERI(val1;…;val30) Ignora celle vuote, valori logici, testo Esempio: =CONTA.NUMERI(A1:A5) =CONTA.NUMERI(A1:A5;30) il 30 è contato come numero CONTA.NUMERI (funzione statistica)

72 72 SOMMA.SE (funzione statistica) sintassi:=SOMMA.SE(intervallo;criteri[;int_somma]) Somma le celle indicate secondo un criterio assegnato. intervallo: l'intervallo di celle da calcolare. criteri: espressi in forma di numeri, espressioni o testo che determinano le celle da sommare. int_somma: celle da sommare. Le celle in int_somma vengono sommate solo se le celle corrispondenti in intervallo soddisfano i criteri. Se int_somma è omesso sono sommate le celle in intervallo. =SOMMA.SE(A2:A6;">=0;B2:B6) =SOMMA.SE(A2:A6;">=0)

73 73 CONTA.SE (funzione statistica) sintassi:=CONTA.SE(intervallo;criteri) Conta il numero di celle in un intervallo che soddisfano un criterio specificato. intervallo: l'intervallo di celle oggetto del conto. criteri: espressi in forma di numeri, espressioni o testo che determinano le celle da contare. = CONTA.SE(B1:B7;">50) = CONTA.SE(A1:A7;"=mele")

74 74 MIN/MAX (funzione statistica) sintassi:=MIN(num1;…;num30) sintassi:=MAX(num1;…;num30) Ignora celle vuote, valori logici, testo Esempio: =MIN(A1:A5) =MAX(A1:A5;30) MEDIA (funzione statistica) sintassi:=MEDIA(num1;…;num30) Ignora celle vuote, valori logici, testo Esempio: =MEDIA(A1:A5) =MEDIA(A1:A5;30)

75 75 MEDIANA (funzione statistica) sintassi:=MEDIANA(num1;…;num30) Restituisce il numero che occupa la posizione centrale di un insieme di numeri dopo che sono stati ordinati. Ignora testo, valori logici, celle vuote. Esempio: =MEDIANA(A1:A8) MODA (funzione statistica) sintassi:=MODA(num1;…;num30) Restituisce il valore più ricorrente in un insieme. Se linsieme non presenta valori duplicati restituisce #N/D. Ignora testo, valori logici, celle vuote. Esempio: =MODA(A1:A8)

76 76 DEV.ST/DEV.ST.POP (funzione statistica) sintassi:=DEV.ST(num1;…;num30) sintassi:=DEV.ST.POP(num1;…;num30) Stima la deviazione standard (o scarto quadratico medio) sulla base di un campione / una intera popolazione. Ignora testo, valori logici Esempio: =DEV.ST(A1:A8) =DEV.ST.POP(A1:A8) DEV.ST.DEV.ST.POP.

77 77 Esempio = CONTA.NUMERI(C2:C101) = MIN(C2:C101) = MAX(C2:C101) = MEDIA(C2:C101) = MEDIANA(C2:C101) = MODA(C2:C101) = DEV.ST(C2:C101)

78 78 Le funzioni logiche hanno come argomenti delle proposizioni che risultano VERE o FALSE. Il valore logico di una proposizione esprime la sua verità o meno e, quindi, può essere VERO o FALSO. Esempio: 5>4 ha valore logico VERO. Partendo da due proposizioni P e Q è possibile definire altre tre proposizioni: 1.P AND Q che ha valore logico vero se e solo se P e Q hanno entrambe valore logico VERO; 2.P OR Q che ha valore logico VERO se almeno una delle due ha valore logico VERO; 3.NOT P che ha valore logico opposto a quello di P.

79 79 AND/OR/NOT (definizione tramite tavole della verità) ANDFALSOVERO FALSO VEROFALSOVERO NOT FALSOVERO FALSO ORFALSOVERO FALSO VERO

80 80 …oppure… PQP AND QP OR QNOT PNOT Q VERO FALSO VEROFALSO VEROFALSOVERO FALSOVEROFALSOVERO FALSO VERO Esiste anche la funzione logica XOR (definibile a partire da AND, OR e NOT) che assume valore logico VERO se solo P o solo Q ha valore logico VERO.

81 81 VERO/FALSO (funzione/valore logica/o) sintassi:=VERO() sintassi:=FALSO() Restituisce il valore logico VERO/FALSO. Il valore VERO/FALSO può essere immesso direttamente nelle celle e nelle formule senza utilizzare questa funzione.

82 82 E/O/NON (funzione logica) sintassi:=E(logico1;…;logico30) sintassi=O(logico1;…;logico30) sintassi:=NON(logico1) Ignora le celle vuote, testo. La funzione E restituisce VERO solo se tutti gli argomenti hanno valore logico VERO; anche se un solo argomento è FALSO viene resituito FALSO. La funzione O restituisce FALSO solo se tutti gli argomenti hanno valore logico FALSO; anche se un solo argomento è VERO viene restituito VERO. Esempio: =E(2+2=4; 2+3=5) =E(A1=A5;VERO) =O(2+2=4; 2+3=6) =O(A1=A5;VERO) =NON(FALSO) =NON(1+1=2)

83 83 Esempio

84 84 SE (funzione logica) TEST (analisi) Azione da eseguire se il test è VERO Azione da eseguire se il test è FALSO sintassi:=SE(test;se_vero;se_falso) Se il test è vero allora esegue lazione se_vero altrimenti esegue lazione se_falso Esempio: =SE(A1>=0;A1*10;-A1) =SE(A1>=0;positivo;negativo) verofalso =SE(test;se_vero;se_falso) supporta 7 livelli di annidamento

85 85 =SE(Test1; azione1;SE(Test2;azione2;azione3)) Test1 azione1 Test2 azione2azione3 verofalso verofalso …..continua

86 86 Test1 verofalso Test2 azione1azione2 azione3 verofalso =SE(Test1;SE(Test2;azione1;azione2);azione3) …..continua

87 87 N.B. =SE(test;se_vero;se_falso) Nel caso in cui il test risulti FALSO e sia stato omesso la parte ;se_falso), allora la funzione SE restituisce il valore logico FALSO. ES: la funzione =SE(3>6; A1+A3) restituisce FALSO. Nel caso in cui il test risulti FALSO e sia stato omessa la parte se_falso), mantenendo il ;, allora la funzione SE restituisce il valore numerico 0. ES: la funzione =SE(3>6;A1+A3;) restituisce 0. Nel caso in cui il test risulti VERO e sia stata omessa la parte se_vero, allora la funzione SE restituisce 0. ES: la funzione =SE(3<6;;A1+A3) restituisce zero.

88 88 Esempio

89 89 Date e Ore Date e Ore possono essere sommate algebricamente e incluse in altri calcoli essendo memorizzate come numeri sequenziali denominati valori seriali interi e frazionari. Excel per Windows utilizza il sistema di data 1900 in cui i numeri seriali corrispondono alle date comprese tra l'1 gennaio 1900 e il 31 dicembre Il 1 gennaio 1900 viene memorizzato come numero seriale 1. Cambiare il sistema di data: Strumenti- Opzioni- cartella Calcolo = G7+H7 Formato data

90 90 ADESSO (funzione data e ora) OGGI (funzione data e ora) sintassi:=ADESSO( ) Restituisce il numero seriale della data e dell'ora correnti, non aggiornata continuamente. sintassi:=OGGI( ) Restituisce il numero seriale della data corrente.

91 91 GIORNO (funzione data e ora) ANNO (funzione data e ora) sintassi:=ANNO(num_seriale) Restituisce l'anno corrispondente a una data. num_seriale: data dell'anno da trovare. sintassi:=GIORNO(num_seriale) Restituisce il giorno di una data rappresentata da un numero seriale. num_seriale: data del giorno da trovare.

92 92 MINUTO (funzione data e ora) ORA (funzione data e ora) sintassi:=MINUTO(num_seriale) Restituisce i minuti di un valore ora. I minuti vengono espressi con un numero intero compreso tra 0 e 59. num_seriale: ora contenente il minuto che da trovare. sintassi:=ORA(num_seriale) Restituisce l'ora di un valore ora. Espressa con un numero intero: da 0 (00.00) a 23 (23.00). num_seriale: orario contenente l'ora che da trovare.

93 93 Esempio =ADESSO() =OGGI() =GIORNO(04-gen) =GIORNO(11/08/1998) =GIORNO(35825) Analogo sopra utilizzando riferimenti =ANNO(05/07/1998) =ANNO(0,07)=ANNO(35981,01) Analogo sopra utilizzando riferimenti =MINUTO( ) =MINUTO(0,01)=MINUTO(4,02) Analogo sopra utilizzando riferimenti =ORA(0,7) =ORA(29747,7)=ORA( ) Analogo sopra utilizzando riferimenti

94 94 Errori ###### larghezza colonna insufficiente per visualizzare il valore #DIV/0 divisione per zero #NOME? riferimento a un nome non valido o inesistente #N/D nessun valore disponibile #RIF! impossibilità di risolvere un riferimento #NUM! utilizzo scorretto di numeri #NULLO! riferimento a intestazione di due aree che non si intersecano #VALORE! tipo di argomento o operando errato

95 95 Esempio Celle cui si fa riferimento Cella che ha generato il valore errato

96 96 Laboratorio di Excel Excel 2000: Formattazione dei Numeri Data Base: ordinamento e filtro Grafici: creazione e formattazione

97 97 Visualizzazione Vs. Memorizzazione Il valore visualizzato in una cella e il valore in essa effettivamente contenuto possono differire. Il valore effettivo di un inserimento è mostrato nella barra della formula, mentre quello che compare nella cella è il valore visualizzato.

98 98 1.selezionare le celle da formattare 2.Formato – Celle 3.selezionare la scheda Numero 4.scegliere una categoria 5.impostare eventuali altre opzioni 6.premere Ok Formattare Scegliere una categoria di formato In funzione della categoria scelta, compaiono una serie di ulteriori opzioni

99 99 Nota Bene 1.Le date e le ore sono internamente memorizzati come numeri seriali: i numeri seriali interi indicano lora 0.00 del giorno corrispondente al numero seriale; i numeri seriali con parte frazionaria indicano una data e unora. 2.Numeri ai quali è assegnato il formato testo mantengono gli 0 iniziali e non sono inclusi nei calcoli di alcune funzioni e formule.

100 100 Formattazione condizionale La formattazione condizionale numerica permette di applicare un formato di visualizzazione che dipende dal valore contenuto nella cella formattata.

101 101 Applicare Formattazioni condizionali 1.selezionare lintervallo cui applicare la formattazione condizionale 2.Formato – Formattazione condizionale 3.selezionare le opzioni appropriate 4.impostare il formato desiderato 5.premere Aggiungi per aggiungere un altro formato condizionale 6.premere Ok per confermare

102 102 …continua Selezione: La nostra selezione di celle contenenti valori. Formato - Formattazione condizionale Valore della cella su cui imporre la condizione Tipo di condizione da impostare Valore della condizione. Impostazione del formato per i valori soddisfacenti la condizione. Aggiungere/Eliminare condizioni Finestra con più condizioni.

103 103 Esempio

104 104 Per individuare celle soggette a formattazione condizionale: - dal menu Modifica scegliere Vai a; - scegliere Speciale; - scegliere Formati condizionali; - ok. Per eliminare fomattazioni condizionale o per modificarle, individuate le celle, dal Menu Formato – Formattazione condizionale è possibile apportare le modifiche desiderato o eliminare del tutto le scelte fatte.

105 105 Database Un Database è uno strumento usato per memorizzare, organizzare e ricercare informazioni. Le informazioni sono organizzate in record ognuno dei quali è composto da campi. In Excel: 1)un colonna è un campo, 2)una riga è un record, 3)le etichette delle colonne costituiscono i nomi dei campi. Database in Excel Nome dei campi: (o intestazione) si trovano nella prima riga del database; Record: occupa una riga, non è possibile lasciare righe vuote; Tipi uniformi: le celle di una stessa colonna contengono informazioni dello stesso tipo; Calcoli: un campo calcolato utilizza le informazioni provenienti da campi della stessa riga. La tabella che rappresenta il database deve essere separata da almeno una riga o colonna vuota da altre informazioni.

106 106 Esempio Campo calcolato: =ANNO(ADESSO())-ANNO(D2) campi record

107 107 Ricerca in un Database Dati – Modulo - Criteri Specificare le informazioni o gli intervalli di informazioni da ricercare. Inserita la condizione di ricerca, premere Trova

108 108 Selezionare il database o posizionarsi su una sua qualsiasi cella. Dati - Ordina … Impostare i criteri di ordinamento. Ordinamento Lordinamento, crescente o decrescente, rispetto a uno o più campi, detti chiavi di ordinamento, ha effetto sui record del database.

109 109 Filtrare i record Filtrare un database permette di visualizzare solo i record soddisfacenti criteri impostati dallutente. I rimanenti record sono nascosti, ma non perduti. Impostare filtri: -posizionarsi su una cella della tabella; -attivare la funzionalità filtro da Dati – Filtro; -compare un filtro per ogni campo del database (Excel posiziona delle caselle di selezione a fianco di ogni nome di campo) ; -selezionare il criterio con cui filtrare i dati, scegliendolo fra quelli disponibili nel menu a discesa che compare clickando sulla freccia del filtro. I criteri disponibili sono: (Tutto) nessun criterio impostato lista di valori che compaiono nel campo criterio di corrispondenza valore (Vuote) si visualizzano le celle che hanno quel campo vuoto (NonVuote) si visualizzano le celle che hanno quel campo non vuoto (Primi 10…) (Personalizza) Eliminare un filtro: - disattivare la funzionalità filtro da Dati – Filtro

110 110 …continua Selezionare il database o posizionarsi su una cella qualsiasi di esso. Dati – Filtro - Filtro Automatico … Menù a tendina con criteri predefiniti di filtro. Filtro attivo sul campo.

111 111 …continua Esempio di opzioni: -(Tutto) nessun criterio impostato -lista di valori che compaiono nel campo criterio di corrispondenza valore

112 112 …continua Esempio di opzioni: -(Primi 10…) criterio di limitazione inferiore o superiore per elemento o per percentuale Se la finestra sopra fosse il criterio di un filtro applicato al campo seguente:voto66 6 verrebbe visualizzato Vengono visualizzati i tre record con i tre valori più bassi del campo su cui è impostato il filtro, ma se ci sono ancora record con il valore più basso dei tre vengono visualizzati anchessi.

113 113 …continua Esempio di opzioni: -(Personalizza) criterio di soddisfacibilità di espressione logica Scegliere filtro personalizzato Impostare la condizione del filtro

114 114 Calcoli su record filtrati Le funzioni effettuano calcoli riferiti allintero database. SUBTOTALE(num_funzione;rif1;…;rif29) (funzione Matematica) num_funzione: funzione da utilizzare per il calcolo dei subtotali 1 MEDIA 2 CONTA.NUMERI 3 CONTA.VALORI 4 MAX 5 MIN 6 PRODOTTO 7 DEV.ST 8 DEV.ST.POP 9 SOMMA 10 VAR 11 VAR.POP rif1;..;rif29: intervalli o un riferimenti di cui calcolare il subtotale Esempio: SUBTOTALE(1;G2:G6)

115 115 Elementi di un Grafico Serie di Dati: valori dipendenti oggetto di rappresentazione sullasse delle ordinate. Categorie: valori indipendenti oggetto di rappresentazione sullasse delle ascisse. Assi: assi cartesiani nel piano o nello spazio. Legenda: lista esplicativa dei dati rappresentati. Griglie: linee orizzontali o/e verticali tracciate nellarea del grafico. asse x asse y legenda categorie titolo titolo asse x titolo asse y area grafico Titolo del grafico, titolo delle ascisse, titolo delle ordinate: esplicativi delloggetto cui si riferiscono. Area: spazio contenente gli elementi del grafico. Il termine serie di dati indica un gruppo di dati correlati tracciati in un grafico. serie

116 116 Bolle, Superficie, Radar: rappresentazione tridimensionale di tre serie di dati. Torta: visualizzazione della scomposizione in porzioni di un totale. Anello: analogo sopra permette la visualizzazione di al più tre famiglie di dati. Linee, Area: visualizzazione dellevoluzione dei valori nel tempo. Dispersione: rappresentazione di due variabili correlate. Istogrammi a colonne, a barre, cilindrici, conici, piramidali: visualizzazione di categorie distinte di dati in un particolare istante. Tipi di Grafico Filmato: file TipiGrafico.aviTipiGrafico.avi

117 117 Autocomposizione Grafico Inserisci – Grafico… oppure premere il pulsante sulla barra degli strumenti standard

118 118 …..continua selezionare tipo e sottotipo di grafico tipo sottotipo premere

119 119 …..continua tipo di orientamento anteprima premere inserire o selezionare lintervallo di dati oggetto di rappresentazione. Se la selezione è precedente la creazione del grafico il campo è riempito automaticamente

120 120 …..continua elementi personalizzabili premere Personalizza- zione degli elementi di un grafico

121 121 …..continua scelta della collocazione del grafico creazione in un nuovo foglio creazione nel foglio corrente premere

122 122 …..continua risultato Il grafico è aggiornato automaticamente ogni volta che i dati cui si riferisce sono modificati. Salvare un grafico significa salvare la cartella di lavoro che lo contiene.

123 123 Esempio Filmato: file CreazioneGrafico.aviCreazioneGrafico.avi

124 124 Modificare Dati nel Grafico Aggiungere/Eliminare dati a un intervallo esistente: -selezionare il grafico -trascinare opportunamente il quadratino di ridimensionamento sul bordo dellarea di origine dati Filmato: file ModificaOrigine1.aviModificaOrigine1.avi

125 125 …continua Cambiare lintervallo di origine dati: -selezionare il grafico -premere -nel passaggio 2 dellautocomposizione impostare un nuovo Intervallo dati -scegliere Fine Filmato: file ModificaOrigine2.aviModificaOrigine2.avi

126 126 …continua Aggiungere serie di dati a un grafico: -selezionare il grafico -Grafico – Aggiungi dati… inserire le celle contenenti i dati da aggiungere nel grafico N.B.: Aggiungi dati… permette di aggiungere dati al grafico non necessariamente consecutivi. Filmato: file AggiungiDati.aviAggiungiDati.avi

127 127 …continua -selezionare il grafico -Grafico – Dati di origine… 1.Individuare serie di dati di un grafico 2.Modificare serie di dati in un grafico 3.Eliminare serie di dati in un grafico 4.Aggiungere serie di dati in un grafico preview nome della serie intervallo di valori sullasse delle ascisse intervallo di valori sullasse delle ordinate aggiungere una nuova serie eliminare una serie esistente previa selezione Filmato: file OrigineDati.aviOrigineDati.avi


Scaricare ppt "1 Laboratorio di Excel Excel 2000: Introduzione Selezione dei Fogli e Navigazione Modifica dellaspetto dei Fogli di lavoro Inserimento di Dati Calcoli:"

Presentazioni simili


Annunci Google