La presentazione è in caricamento. Aspetta per favore

La presentazione è in caricamento. Aspetta per favore

Vanzulli Laura OGGETTI BELLI CON IPLOZERO Didattica della Matematica Prof. Lariccia Giovanni.

Presentazioni simili


Presentazione sul tema: "Vanzulli Laura OGGETTI BELLI CON IPLOZERO Didattica della Matematica Prof. Lariccia Giovanni."— Transcript della presentazione:

1 Vanzulli Laura OGGETTI BELLI CON IPLOZERO Didattica della Matematica Prof. Lariccia Giovanni

2 Oggetti belli con Iplozero Dopo aver dato una lettura e visto diversi tipi di esercizi sul libro, ho deciso di provare a riprodurne alcuni, ecco il risultato del mio lavoro

3 IL ROSONE Dopo aver provato a capire le diverse istruzioni che compongono il disegno del Rosone, mi sono divertita a modificare colore, dimensione e forma per realizzarne uno tutto mio

4 ISTRUZIONI Per quadrato ripeti 4 [avanti 150 destra 90] fine per rosone ripeti 12 [quadrato d 30] fine tax 4 ascolsfondo [ ] bianco giallo spessore 20 rosone rosa spessore 10 rosone

5 RISULTATO

6 LA SEMPLICITA DI IPLOZERO Una volta scritto nel foglio di Iplozero le istruzioni base, basta modificare alcuni parametri ed ecco per magia che il nostro Rosone cambia forma, colore e dimensioni. Facendo queste esercitazioni mi sono resa conto di quanto è semplice realizzare disegni, modificarli, reinventarli. Con piccoli accorgimenti ho realizzato due immagini molto differenti

7 ISTRUZIONI ROSONE 2 Ho evidenziato le modifiche che ho apportato al mio codice Per quadrato ripeti 4 [avanti 150 destra 90] fine per rosone ripeti 24 [quadrato d 15] fine tax 4 ascolsfondo [ ] bianco verde spessore 10 rosone rosso spessore 5 rosone

8 RISULTATO ROSONE 2

9 MULTIQUADRATI Unaltra figura geometrica che mi ha colpita e mi ha spinta a realizzare è stato il multiquadrato. Anche per questo disegno ho voluto evidenziare la semplicità con cui è possibile realizzare due disegni differenti con poche modifiche sul codice

10 SPIEGAZIONE Guardando il risultato sembrerebbe una figura molto complessa, ma in realtà è più semplice di quello che sembra. Ho creato una funzione chiamata multiquadrato dove ho scritto più istruzioni per disegnare quadrati di diverse dimensioni. La funzione principale invece richiama 4 volte la funzione multiquadrato cambiando colore e posizione iniziale della tartaruga. Ed ecco la magia di Iplozero…

11 ISTRUZIONI per quadrato :lato ripeti 4 [a :lato d 90] fine per multiquadrato quadrato 20 quadrato 40 quadrato 60 quadrato 80 quadrato 100 quadrato 120 quadrato 140 quadrato 160 quadrato 180 quadrato 200 fine tarta.apparecchia sfondonero bianco spessore 6 rosso1 multiquadrato destra 90 blu1 multiquadrato destra 90 verde multiquadrato destra 90 giallo multiquadrato

12 RISULTATO

13 SPIEGAZIONE In questa seconda esercitazione ho voluto realizzare unulteriore funzione per alternare i colori in ogni quadrante. Le istruzioni risultano più complesse, ma il risultato premia lo sforzo.

14 ISTRUZIONI per quadrato :lato ripeti 4 [a :lato d 90] Fine per multiquadrato1 quadrato 20 quadrato 60 quadrato 100 quadrato 140 quadrato 180 fine per multiquadrato2 quadrato 40 quadrato 80 quadrato 120 quadrato 160 quadrato 200 fine tarta.apparecchia sfondonero bianco spessore 5 blu multiquadrato1 azzurro multiquadrato2 destra 90 rosso multiquadrato1 arancione multiquadrato2 destra 90 verde multiquadrato1 verde5 multiquadrato2 destra 90 giallo multiquadrato1 giallo4 multiquadrato2

15 RISULTATO

16 LOROLOGIO 1 Ho cercato di realizzare un primo orologio molto semplice, con un unica tipologia di lancetta

17 ISTRUZIONI per lancetta avanti 200 cerchio 50 cerchio 30 indietro 200 fine per quadrante ripeti 12 [lancetta destra 30] fine tarta.apparecchiax 4 ascolsfondo [ ] grigio2 cerchio 280 blu5 spessore 5 quadrante

18 RISULTATO

19 LOROLOGIO 2 Dopo aver realizzato il primo orologio, ho cercato di crearne unaltro più particolare partendo dalle istruzioni già scritte. Il secondo orologio è composto da due tipologie di lancette, lunghe per i numeri pari e più corte per quelli dispari. Ho disegnato altre ad un cerchio anche un quadrato in modo da ottenere una punta sulla lancetta. Questo disegna risulta più complesso rispetto al precedenti

20 ISTRUZIONI per lancettaGrande avanti 200 cerchio 50 sinistra 45 quadrato 50 destra 45 indietro 200 fine per lancettaPiccola avanti 150 cerchio 40 sinistra 45 quadrato 40 destra 45 indietro 150 fine per quadranteGrande ripeti 6 [lancettaGrande destra 60] fine per quadrantePiccolo destra 30 ripeti 6 [lancettaPiccola destra 60] fine tarta.apparecchiax 4 ascolsfondo [ ] grigio2 cerchio 280 cerchio 215 blu5 spessore 5 quadranteGrande rosso5 quadrantePiccolo sinistra 30

21 RISULTATO

22 Considerazioni Lordine dei lavori che ho descritto rappresentano il grado difficoltà che ho incontrato utilizzando Iplozero. Allinizio ero spaventata, non sapevo come disegnarle, ma partendo con figure semplici e piano piano inserendo sempre delle nuove variabili sono riuscita ad ottenere figure sempre più complesse. Mi sono divertita molto, con questo strumento è possibile disegnare senza usare il mouse, come facevo con il più classico Paint, ma con lutilizzo di istruzioni.


Scaricare ppt "Vanzulli Laura OGGETTI BELLI CON IPLOZERO Didattica della Matematica Prof. Lariccia Giovanni."

Presentazioni simili


Annunci Google